MongoDB Realm Task Tracker Tutorial: "Function not found"

I am building sample Task Tracker app from here:

  • Following the instructions, I created the back end using the CLI tools.

  • I downloaded the sample iOS app and I am able to create accounts, log in, create data.

  • When I try to add a team member using email to share data I get an error: “function not found”

  • I’ve attached screenshots to shot the function is setup on the back end with the proper names.

  • I suspect a permission issue, but I’m unable to resolve the issue.

I have set up the backend on more than half a dozen servers during the last week to test the response times from various server locations and did not come across this error. For the front-end I used React Native, Node.js, CLI and the iOS project using the final Github versions to prevent typing errors. The tutorials do have a few bugs and syntax errors, but the Backend always worked on every client I tried, if I correctly followed every step.

One permissions issue I had, was due to my mistake in following the backend tutorial: make sure you select “Project Owner”

Your issue may be elsewhere. Also check, if you see all the functions in your Realm App. If my suggestion does not work, just set it up again from scratch on a different MongoDB server.

1 Like

I’ve the same issue. what can I do?