MongoDB Pods Restarting Frequently on OpenShift - "rename WiredTiger.turtle.set permission denied" Error

Dear MongoDB Support,

I’m writing to report an issue with my MongoDB pods deployed on OpenShift. The pods are experiencing frequent restarts, and the logs indicate the following error message:

rename WiredTiger.turtle.set to WiredTiger.turtle permission denied

I’d appreciate your assistance in understanding this error and resolving the pod restarts.

Here are my specific questions:

WiredTiger.turtle.set File:

What is the purpose of the WiredTiger.turtle.set file?
Why is this file being renamed, and what triggers this behavior?
We tried simulating the creation of the WiredTiger.turtle.set file on our lab , but we do not see mongo generating this file. Once we tried to create the file by hand , and it cause the pod to restart.

Error Impact:

Why does a permission error renaming this file lead to the pod shutting down?
Is there a way to disable this behavior and allow the pod to continue running, even if the rename fails? (This would be for troubleshooting purposes only)
I’ve included relevant system information below (replace with your actual details):
MongoDB Version: 4.4
MongoDB Deployment Configuration: Running as pods over openshift platform using NFS as persistence volume.

Thank you for your time and support.
Guy