[Errno -3]

Hi - I recently seemingly randomly came across this error attempting to access my MongoDB using PyMongo.

( replacing the db host name, which I have triple checked matches what’s posted under the database connect menu)

<ServerDescription (’, 27017) server_type: Unknown, rtt: None, error=AutoReconnect(‘ [Errno -3] Temporary failure in name resolution’)>

Everything was working smoothly until roughly 6 hours ago. No changes were made whatsoever, so I am unclear as to what is suddenly causing this error.

I have tried downgrading, and upgrading, exact same error appears. I double checked the host

Would greatly appreciate it if someone could point me in the right direction!

Thank you!


Did you:

  • check the state of the server in Atlas (supposing you use atlas) ?
  • try to connect with a different client ?

Thanks for the reply.

I have tried connecting from another client and works fine. I suppose this is an issue with Replit. It seems it is a known issue without a definitive fix yet:

I have spoken to Atlas support and confirmed there are no issues on that side. I will continue trying to get ahold of Replit support in this case.

Thanks again!

hey @Cheshire_N_A

I am having similar issue using AWS Lambda.

Could you figurate out what it was or how to fix it?