Mongodb is not updated properly from 4.2 to 4.4

I was using mongodb 4.2.9 on ubuntu 18.04

I installed it with package manager.
Now I to update it to 4.4 version used package manager following --> instructions.

Installation was ok but when I write mongod -version command it shows - db version v4.2.9.
I tried to re-install again it says
mongodb-org is already the newest version (4.4.1). but mongod -version command it shows - db version v4.2.9.
How can I get rid of this problem?

dpkg -l|grep mongo

ii  mongodb-compass                            1.18.0-1                                         amd64        The MongoDB GUI
ii  mongodb-org                                4.4.1                                            amd64        MongoDB open source document-oriented database system (metapackage)
ii  mongodb-org-mongos                         4.2.9                                            amd64        MongoDB sharded cluster query router
ii  mongodb-org-server                         4.2.9                                            amd64        MongoDB database server
ii  mongodb-org-shell                          4.2.9                                            amd64        MongoDB shell client
ii  mongodb-org-tools                          4.2.9                                            amd64        MongoDB tools
rc  mongodb-server                             1:3.6.3-0ubuntu1.1                               all          object/document-oriented database (managed server package)

Says just mongodb-org is updated.

Hi @Md_Mahadi_Hossain,

How did you install MongoDB? Was it via package reload or specific version install command?

Also is MongoDB running while you do this?


I installed it by package reload and by sudo apt-get install -y mongodb-org .
I solved this problem latter by apt-get upgrade and restart the machine.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.