Mongodb immediately exits with error 132, and will not ressurect

No lie, I am a complete novice to MongoDB, but I was using Bitnami’s dockerized version of it for the database backend of a site that I host. I went to start a cloud9 container to make changes to static html files on the server, and noticed that MongoDB exited. I immediately killed the cloud9 container and removed it. Then started to raise the MongoDB container again, and it immediately exited with error code 132. I have tried numerous things, and still MongoDB exits with error 132. I even tried back versioning it, and that sure as heck didn’t work. Furthermore, I attempted to start MongoDB manually from within the container, which resulted in the same error.

Assuming this error had to do with Bitnami, I have attempted to get support from them, without much success, but they did refer me to MongoDB for help. So here I am.

This has been terribly irritating…

Hi @anoduck_theduck
Welcome to the community!!

Since the MongoDB was running while a change was made in the application, MongoDB ends with illegal instructions and hence received an error code of 132.
Could you please let us know the version of MongoDB you are using for your application?
Also, could you let us know details of the hardware and OS along with the logs containing the same error code.


1 Like

MongoDB Version: 5.0.6
Host OS: Alpine Edge
Container OS: Debian 10
Docker Image: bitnami/mongodb
CPU: dual core
Available RAM: > 2GB
Storage Engine: Wired Tiger

The computer was thrown away by someone because it had a bad cdrom, so I just removed the cdrom, and it has been running fine for years. Not too familiar with the specifics of it.

I also know 5.0.6 should not run without AVX, but the container has been running good for weeks until now.

Hi @anoduck_theduck

Thanks for the sharing the details. Would need some further information for further debugging.

Could you please share the logs which shows the 132 error code along with output of /proc/cpuinfo


you are very kind in your attempt to help me, but I cannot take advantage of your kindness. You have other users to help, who are not nearly as ignorant about the technology as I am. The data in MongoDB can be added again at a later point in time. I am going to scrap it, and start all over from the beginning.

The Bitnami development team finally bluntly told me they will not provide support, and then insinuated that I misconfigured the container. They wouldn’t tell me what I did wrong, just that I did something wrong. Misconfiguring a docker image would be difficult to accomplish, due to it being so easy to configure correctly. Their image of MongDB does not generate logs, regardless of the settings within the docker-compose.yml, nor does it create new users. So, you are forced to use MongoDB with an empty password. This creates issues that are now a game changer.

I am going to build my own container of MongoDB with version 4.2, one that actually works. This will provide me a better understanding of the technology, and avoid the shortcomings of Bitnami’s image.

I sincerely appreciate all your help. MongoDB is less mysterious now, and I believe I can work with it. Thanks for this.

1 Like