Mongodb-driver-sync and mongodb-driver-core

Hi Team,
Mongo db driver sync version 4.x is automtically donwloading mongodb-driver-core version 4.2.2.
And in my application hazelcast 5.2.3 version is trying to connect to mongodb using mapstore.
And mongo sync is expecting the a class com/mongodb/internal/diagnostics/logging/Loggers
which is not there in mongo-driver-core. But I see com/mongodb/diagnostics/logging/Loggers.
Which version of driver sync would give me correct mongo-driver core.

is there any update on this issue?