MongoDB Compass not moving past "Activating Plugins"

I have just installed MongoDB Compass for the first time but it can not pass " Activating Plugins" stage.
Please help so I can progress on my course

What is the version you are installing
Which browser you are using
Make sure no firewall,anti virus,vpn issues preventing install

Please check this link

MongoDB Compass Stuck at Activating Plugins

Hi @Wellington_Majora,

Any update on this :point_down:

~ Shubham

I have tried but dont seem to be able to solve this problem. I have tried reinstalling and it successfully installs. I can launch the app and it initialises, loads preferences, load plug ins but then becomes stuck at activating plugins. See attached

Hi @Wellington_Majora,

Please share the following details :

  • Name and version of your operating system

  • Version of Compass that you have installed

Also, have you tried installing any older version of Compass ?

~ Shubham

My OS is Windows 10 Home Edition

MongoDB Compass 1.21.2

My assignment was due today but I have not been able to complete it. Can I get an extension?

Hi @Wellington_Majora,

This :point_down:

Please try an older version of Compass 1.20.0.

Unfortunately, you cannot get any extension. You can enrol in the next offering of M001.

~ Shubham

@Wellington_Majora you can just add this path to your path


This worked well for me! Using win10