MongoDB Compass non existing in Services on Windows

Hello, I downloaded MongoDB Compass on my Windows laptop. I want to run MongoDB Compass as a service but I cannot find it in Services. Apparently I would need to reinstall Mongo and to select service option when installing. However, there is no service option upon installation. I am downloading MongoDB Compass from here: The file “mongodb-compass-1.40.3-win32-x64.exe” downloads on my machine. When I click and run this file, MongoDB Compass installs and opens. Of course, when I tried to connect to local, it fails as I need to run it as service. But it cannot be found in Services and no option to select service when installing is provided. Please advice. Thank you very much,

Did you install mongodb server inside windows machine.

Do check if mongodb properly installed or not

Open cmd


Mongod --version

If written internal or external command not found reinstall mongodb


Set path of mongodb inside Environment Variables

1 Like

I do not think that Compass is meant to be run as a service. It is a client application. Perhaps you are confused between Compass, then client, and mongod, the server. The latter can be run as a service. But it is not the same download.

It fails to connect because mongod, the server, is not running.

To install and run mongod, see

If you still fail to connect, then perhaps, you will be better served with Atlas:

1 Like

Thanks for your reply, indeed it seems that I embarrassingly failed to first install the actual mongod. I went straight for Compass, which is only the UI

Of course, it all makes sense now - Compass is merely the UI for mongo! Thanks for pointing that out Steeve, I just installed MongoDB Community which I now can access successfully via the Compass.
Thanks again, Astig


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.