Mongodb compass- host and port provided is not work

Host and port given is wrong ?

Mongodb is not start up at the host and port provided


It actually worked fine for me.
Are you able to confirm that you’re not behind a firewall and can make connections outgoing to 27017?
If not I suggest you copy/paste the address etc to make sure you have them correct.
Hope that helps.

Hi Kenth,

Please take a look at this post here.

Let me know if it still doesn’t work.



i still facing the same issue.
i did try to ping to the server provided. It show me as below

as well as i did on this, as below


Any updates on this issue ?


Hi Kenth_31619,

Sorry for late response.

Here are some checks you can do to make sure everything is right!

Let me know if it works!



It seem like the connection issue again.
Please find the result as attached below.

Hi Kenth_31619,

Seems like your network is blocking the requests. Make sure by doing ping

Also, for details, check here.



Please find the result as per attached below:

Have you tried telnet and everything else?

Screen Shot 2018-10-16 at 3.08.28 PM.png1352x862 121 KB

~$ telnet 27017
Connected to

  • Also, can you go to your browser and try . The output should be:
    It looks like you are trying to access MongoDB over HTTP on the native driver port.
    If you get the above message, then that means you can access Atlas.

If you have, please copy/paste this command directly and wait for it to connect:

mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

Also check for double quotes if you get any syntax error or so.


1 Like

Yes MongoShell works for me, not COMPASS