mongoDB Compass display issue on MacOS Big Sur

Hey guys,

I have installed the latest version of mongoDB Compass (v 1.28.1) for macOS - Big Sur. When I run the app, I see that the app is not rendering all the items. For example, the button text is not showing up and even the buttons look weird. And I am pretty sure when I compare that to windows version, that there is also some default text that is now displaying. Please look at the attached screenshot.

Any help on resolving this is appreciated.


Hey @K_P thanks for reporting the issue! Unfortunately we are not able to reproduce, so looking for the root cause might not be easy. If possible, can you please try out a few things for us:

  • Can you try previous version of Compass (you can find an installer here) and tell us if you’re getting the same result?

  • Can you open devtools console with a hotkey or from the view options (as shown on the image below) and tell us if you see any warnings/errors there?

  • If there are none, can you reload Compass (first option in the menu in the image above) while the devtools are open and tell us if there are any errors there now?
1 Like

Thanks for your response.

I installed the v1.27.1 but that yielded in the same result. I did see an error in the devtools which I have attached with my comment. However, once I reloaded the app from the View > Reload, that error disappeared.

Screen Shot 2021-08-20 at 10.39.45 PM