MongoDB Compass 1.21.1 doesn't start on Windows 7

Hello, I am new in MongoDB, I installed shell & its working fine. I also installed MongoDB compass, when I run it displayed blank screen & not able to do anything … I tried lot but not able to solve this problem…

Are you able to connect by shell?
What is your connect string you used for Compass?
Or check connection parameters you used


Hi @Ravindra_Negi and welcome to the community!

Can you please answer a couple of questions so that we might be able to help out:

  • What version of MongoDB compass you installed (both version number and whether it was Stable, Community, Read-Only or Isolated editions)
  • What version of Windows are you using?
  • Does the black screen appear right after opening Compass or does it happen while trying to connect to a MongoDB instance?

Hi, I am using compass version 1.21.1 stable.
OS Windows 7
Blank screen appear right after opening compass, as I posted screen shot in my previous post.
Shell is working fine.

Yes, shell is working fine. But not able to see anything in compass screen due blank screen. Even not getting option to set host string or connect string. I have mentioned screen shot in previous post

Thanks for the info @Ravindra_Negi! Unfortunately I don’t have a Windows 7 machine to test on, but hopefully one of the engineers that work on Compass will see this soon and be able to help provide ideas.

I was thinking that maybe Compass was not compatible with Windows 7, but according to the install notes it is. It also seems that Compass ask you to install the required version of the .NET framework if it’s not already installed.

As for my asking when the blank screen appeared, a screenshot only shows what’s happening, not when it happens. Thanks for stating that it’s right as soon as you start the application up as that will help the Compass engineers troubleshoot.

As for next steps, that I’m not sure you stated

but you didn’t state what those things are. :frowning:

Like I say, I know that the Compass team does look at posts, so hopefully one of them will be by soon to help.

You may want to try to reinstall Compass. Maybe install the latest version 1.21.2 (it is just released).

I just now installed Compass 1.21.2 on Windows 7. Works fine, and I use it with MongoDB Server version 4.2.3.

I have the same issue. W7, blank screen on startup of Compass. have installed 2X exe and msi, no difference, just hangs. 1.21.1. rebooted in between. W7 home premium fp 1. does respond to close action.

Hello @Rainer_Richter, welcome to the community.

I am using similar Windows 64 bit version. I actually, installed my Server 4.2.8 and Compass 1.21.2. I was doing some re-organizing my programs and doing housekeeping on my laptop. But, I downloaded the ZIP version of the programs. They installed and work fine.

Thanks, I tried the GA zip and the beta versions, same issue. It’s running, I see 3 processes in task manager just no gui. I’m getting a new W10 PC next week as a workaround. :slight_smile:

Solved! After installing .net 4.8 and various other windows updates, it works now.

1 Like