MongoDB Community Server Docker Image Containers Fail To Bind To ReFS Volumes


I run a MongoDB Community Server Docker container using the latest version of the official MongoDB, Inc. provided image.

It was working OK until I tried to bind the data directory of that image to a directory located on a ReFS volume. It then kept restarting over and over with almost no delay between restarts. I tried tracking down the problem and noticed this error:

"msg":"__posix_open_file:815:/data/db/WiredTiger.wt: handle-open: open","error_str":"Operation not permitted","error_code":1
"msg":"Failed to start up WiredTiger under any compatibility version. This may be due to an unsupported upgrade or downgrade."
"attr":{"reason":"1: Operation not permitted"}

I tried binding the data directory to one on an NTFS volume, and it worked OK.

Is ReFS not supported?

I hope someone can provide some insight on this.

I am still waiting :man_shrugging:t2:

XFS and NTFS are the recommended and supported filesystems.

1 Like