MongoDB Community 5.0.12 Illegal instruction (core dumped) ubuntu 20.04.5 LTS

Hi there,

I’m trying to get MongoDB 5.0.12 running on ubuntu 20.04.5 LTS, but whenever I try to start the mongod service through systemctl, I get the below output.

user@ubuntu:~$ sudo systemctl start mongod
user@ubuntu:~$ sudo systemctl status mongod
● mongod.service - MongoDB Database Server
     Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
     Active: failed (Result: core-dump) since Wed 2022-12-14 10:43:06 UTC; 4s ago
    Process: 6318 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=dumped, signal=ILL)
   Main PID: 6318 (code=dumped, signal=ILL)

Dec 14 10:43:05 ubuntu systemd[1]: Started MongoDB Database Server.
Dec 14 10:43:06 ubuntu systemd[1]: mongod.service: Main process exited, code=dumped, status=4/ILL
Dec 14 10:43:06 ubuntu systemd[1]: mongod.service: Failed with result 'core-dump'.

At first I was trying to get 6.0.3 running but this gave me the same result, which is why I decided to switch to 5.0.12, which I already have running on a different development oriented ubuntu 22.04 machine.
Reinstalling the OS and trying the installation again from scratch gives me the exact same result.

Running mongod --config /etc/mongod.conf returns Illegal instruction (core dumped).
Running sudo mongod --config /etc/mongod.conf returns Illegal instruction.
Running sudo mongod --logpath ~/mongod.log returns Illegal instruction and does not create a log file.

I’m running out of ideas and could use some help :confused:

It is a know issue discussed at length. See Search results for 'status=4/ILL' - MongoDB Developer Community Forums


Thanks for the reply, turns out (in my case at least) the server I was using had an older CPU which does not support the AVX instruction set required by MongoDB 5.0+.

For future reference, see this list of CPU’s which support AVX: Advanced Vector Extensions - Wikipedia

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.