MongoDB 5 for Alpine 3.18

Hi everyone. We need MongoDB 5.x version (ideally 5.0.9) for the following version of Alpine Linux distro: 3.18-2024.01.18.
We noticed that the latest available version as APK for Alpine is Mongo 4.0.2.
Is there any APK for Mongo 5.x? Otherwise, are there any guidelines fro building Mongo 5.x for this version of Alpine?
Thanks, Mattia