Mongodb 5.0 Depends: libssl1.1 (>= 1.1.1)

Hello There,

I am getting below error while installing Mongodb 5.0.22 on Debian 12

10.52 mongodb-org-mongos : Depends: libssl1.1 (>= 1.1.1) but it is not installable
10.52 mongodb-org-server : Depends: libssl1.1 (>= 1.1.1) but it is not installable
10.52 mongodb-org-shell : Depends: libssl1.1 (>= 1.1.1) but it is not installable
10.52 E: Unable to correct problems, you have held broken packages.

I want to check whether Mongodb5.0.22 can build with libssl3 or it is dependent on libssl1, I have checked several blogs which says install libssl1 directly to install mongodb5.0.22 ( I need 5.0.22 version for migration purpose)

Please guide,
SAM

Currently only MongoDB 7.0 is supported on Debian 12