MongoDB 4.4.5 Help with Primary?

Hello so I’m kinda in need of some help.

I’m working on Mongodb with Elasticsearch in Graylog. I’m trying to make a high availability setup.
It all worked out with 4.4 mongodb but 4.4.5 has been Challenging.

The enforce command i found for mangodb primary isn’t working.
cfg = rs.conf();
cfg.members[0].priority = 2;
cfg.members[1].priority = 1;
cfg.members[2].priority = 1;

and making a Authorized user for database admin can login but he can’t use commandos such as rs.stepDown() however it worked without the Authorized user.

Are all the commands really that different from last update to the newest?

What steps did you take to create this user and what roles did you grant?
Did the user authenticate successfully?
What is the error returned from rs.stepDown()

1 Like

Dear Chris tyvm for your messages on both posts.

However i just used the downgraded command seen below
sudo apt-get install -y --allow-downgrades mongodb-org=4.4.4 mongodb-org-server=4.4.4 mongodb-org-shell=4.4.4 mongodb-org-mongos=4.4.4 mongodb-org-tools=4.4.4

for some reason it kept giving me some issues on 4.4.5 which i havn’t seen on 4.4.4 but i now looks like that 4.4.4 the downgrade i did might not have been the best idea either.