Mongod 7 windows service refuses to start after Authorization enabled

After creating admin user and changing Authorization to enabled, mongodb service does not start with the message:

Can someone help?

Check your config file again
Do not use tab but use space bar
Most likely Yaml indentation issue

I had already read and applied what you said, but no change…

Check two places for errors:

  1. Windows EventViewer
  2. MongoDB Logs

OK - after spending two days browsing through different answers and none of it worked, I discovered what is wrong with the windows version of MongoDb configuration file and why you cannot turn authentication on - the correct configuration node should be like this:

security:	
 authorization: "enabled"

All the examples that I found regarding this issue give the following example:

security:	
 authorization: enabled

I know that I’m late for the party, but who knows, maybe it will help someone someday :-).

1 Like

Both are valid yaml, I just started using both versions.

I wasn’t able to start the Windows service using the second version, only with the first one.