Mongo Restore Operation Failed

We have one replica set and one standalone. We want to take a mongodump from replica set and restore at standalone. The dump operation was successful, but I am getting the following error while restoring.
How we can solve this ?

How did you “make the dump” ? (eg. what command used)

(post deleted by author)

mongodump --port 27018 -u admin -p “aydvbdvahvd” --authenticationDatabase admin --db catalog -c test_backup --out /Products/mongodb/test_backup_dump/

The error looks like the server is checking if current node is a primary which shouldn’t happen as this is a standalone instance.

you can double check if this server is indeed running as a standalone machine. In addition, you can try mongoexport instead. This is plain text file and it’s easier to troubleshoot in case of errors. (maybe in the mongodump result file, something related to replica set is there? i don’t know)

Hello Kobe,

Problem solved. The cause of the problem is that you have incorrectly configured the replica field in the conf file. After fixing the conf file, we tried the reset operation again. It worked flawlessly. Thank you very much for your support.

Kind regards