Mongo Atlas Deployment stopped working

We are using the mongo atlas Deployment using the git hub as our source of truth.

A few days ago it started failing with the following message:

Failed: error validating ‘mongodb-atlas’ service: expected ‘uri’ to be a ‘string’, but instead found a ‘null’

Tried to resync the files with the app service CLI but no luck.

Any advices on how to fix this?

Hi @Leonardo_Bispo can you share more details so we can best advise? In particular, can you include link to GitHub repo in question, your deployment details including Terraform/3rd party integration scripts, and full error message/logs if available?

If easier feel free to create an issue on the appropriate MongoDB Atlas GitHub Repo directly if helpful, for example - Issues · mongodb/terraform-provider-mongodbatlas · GitHub

I’ve got the same on one of my apps.

Failed: error validating ‘mongodb-atlas’ service: expected ‘uri’ to be a ‘string’, but instead found a ‘null’

@Zuhair_Ahmed it is using the " App Services GitHub Integration " rather than a custom terraform/3rd party script.
It seems like if i commit anything from the UI it updates GitHub correctly however anything which is committed into GitHub is then rejected by Atlas. (even something as trivial as a comment in a function)

1 Like

Try re-syncing the deployment file with app cli again. use the appropriate command to re-sync the configuration file.

I started experiencing the same thing on 3/26. No change in the configurations. I exported the last successful deploy and the one failing, and diff them, and see no difference. I also make the change in the UI and push to Github, and it is successful. The exported deployment and the pushes from Atlas UI to github repo all are identical to the failed deployment (just changing a Readme file to trigger a deploy/Github webhook). Something appears to have changed with the integration.

3 Likes

I already tried to do this. Still same issue

1 Like

@john_sam This can be replicated.

  1. create an app in the ui
  2. use the cli to export it
  3. link github and set automatic deployment
  4. commit and push the exported app (no changes)

Result:
Failed

: error validating ‘mongodb-atlas’ service: expected ‘uri’ to be a ‘string’, but instead found a ‘null’

We solved this by upgrading to their new CLI package “atlas-app-services-cli”. The only special thing I needed to do was ensure the cluster was set in the data_sources/mongodb-atlas/config.json file (“config”: { “clusterName”: … } and it seems functions and triggers must also have identical names now.

I tried to update the atlas cli and resync the project. No lucky