M001: Chapter1-Lab2: connect to Sandbox fails from IDE


I am working on Lab2 of Chapter1. I am not able to connect to Mongodb via IDE.

I have db user created as m001-student. It doesn’t ask me to enter the password as mentioned in the instructions of the lab. I did review related topics to this as well.

Here is the screenshot.



1 Like

You have to run the command in terminal area.Looks like you are in editor area of IDE
After pasting or typing the connect string hit enter

1 Like

Duh!! you are right!!

Thanks so much for your response!! :slight_smile:

I’m coming up with the same error and I’m not sure where I’m going wrong.

Please show the screenshot
Are you running the command in right area of IDE?
Did you hit enter?
Does your cluster name starts with Sandbox?


Being weekend i could not respond. Sorry!

I am glad Ramachandra responded to you. Are you still having issue?

All i had to do is instead of giving the connect command in the editor, i have it in the Terminal window which is right below the editor window. Also the gave the Database name as ‘test’.

Let me know if that helps.


Hi @Bertan_Ozbek,

Let us know if you are still facing any issue.

Hey Hi,
I am having following issue. Kindly help me out on this

What is the name of your cluster?

From the error message, you did not named it Sandbox as required.

Plz find the attachment and let me know the name of Cluster, because I didn’t changed name of cluster. plz help me this I am struggling from 2 days on this.00. mongoDB

Your cluster is named Cluster0 but the requirements are for it to be called Sandbox. It is best to terminate this cluster and create one with the appropriate name.

Hi Shri,

You named your cluster as Cluster0. you cannot rename your cluster. Instead terminate the cluster and recreate one an name it as sandbox.

Steps to terminate and recreate the cluster:
Navigate to your clusters and click on three dots(…). you will see Terminate. Click on Terminate.
once you terminate. You will see an option to create cluster.
Follow the steps to create the cluster.
Name your cluster as sandbox.

Hope this helps. Let me know if you still see issues.


This part of the lecture and discussion was very confusing because it looks like it is already named “sandbox.”

mongo “mongodb+srv://cluster0.uejju.mongodb.net/sandbox” --username m001-student

That should do it, and it doesn’t.

Hi Susan,

The connect string has sandbox as part of the URI. Before you connect, you should name the cluster as sandbox. Once you name your cluster to sandbox, then your connect string will work.

Hope this helps with your confusion.


In this URI,

the cluster is named cluster0. The part of the URI where you have sandbox written is default database to which mongo will connect. Please consult https://docs.mongodb.com/manual/reference/connection-string/ for more information about the format of a URI.

The name cluster0 is the default name that Atlas used. You must change this name to sandbox as the requirements ask. Since a cluster cannot be renamed, you will have to terminate this cluster and create a new one with the requested name.

hello if you are up there / please help me completing the lab2 taks as i am stuck on it since days please help me??

hello coders please help me connect to solve my issue so that i can complete my lab2 tasks i am stuck on it?/

Hi Shradda,

What is your issue? Can you help us understand where you are stuck? Brief description and a screenshot would help.


1 Like

I have given right details and click on enter but it doesn’t work for me. why ?