Linux (Slackware) Solution: Mongodb-compass can't open after install

I have successfully installed mongodb-compass in the operating system that I am using (I use slackware 14.2). but after that I can’t open the application via the terminal command and an error message appears: “segmentation fault mongodb-compass”. Should I use Ubuntu inside my slackware with virtual box ?

1 Like

I have the exact same problem with Ubuntu 18.10; people using Fedora complain about the same thing

4 Likes

Yeah, now I have succeded to run mongodb-compass on my linux (slackware). but the way I use it is with docker. My solution :

1.I’am make Dockerfile with content like this :
FROM ubuntu:16.04
MAINTAINER Admatic Engineering Team@ADMATIC.IN
ENV DEBIAN_FRONTEND=noninteractive
RUN apt-get -y update
RUN apt-get install -y libsecret-1-0 libgconf-2-4 libgtk-3-0 libxss1 libnss3 libasound2
ADD https://downloads.mongodb.com/compass/mongodb-compass_1.16.3_amd64.deb /opt/mongodb-compass_1.16.3_amd64.deb
RUN cd /opt/ && dpkg -i mongodb-compass_1.16.3_amd64.deb
CMD mongodb-compass

and then…
2. i’am build the Docker with this command:
docker build -t mongodb-compass .

then…
3. Running mongodb-compass from terminal like this :
docker run --net=host --env=“DISPLAY” --volume="$HOME/.Xauthority:/root/.Xauthority:rw" mongodb-compass

references : https://bit.ly/2LFGtkA

Happy learn…, i hope my solution can help you too

3 Likes

I have somewhat different issue. When I download the mongodb-deb file it does not open through the software, it opens through the Archive Manager. So I am unable to install it.

I assume you are dealing with debian packages. you can use this command via terminal
sudo apt install /path/to/package/name.deb

1 Like

I down the zip and create a folder in documents and stract there, this work for me :thinking:

Got the same problem with the stable version on Ubuntu 19.04. Downloaded the beta release, and it worked well.

Neither version worked for me, the window frame would come up, but then it would hang

piping output gets it to work

$ mongodb-compass 2>&1 | tee -a mongodb-compass.out
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Same problem here ( Compass 1.18.0 on Ubuntu 18.04.2 LTS) - it keeps “Loading…” forever - but solved: using an old version (1.14.1).

My steps [after uninstall the 1.18.0 version]:

wget https://downloads.mongodb.com/compass/mongodb-compass_1.14.1_amd64.deb
sudo dpkg -i mongodb-compass_1.14.1_amd64.deb
mongodb-compass
1 Like

Hi @Leonardo_93208,

Thanks for notifying the issue!!

Please allow us sometime to check the issue and we’ll update you as soon as it gets fixed.

I hope you are able to work on older version of Compass. If you have any doubt, please let me know.

Thanks,
Sonali

Hi @Leonardo_93208,

Please try downloading Compass 1.18.0 version now. I have replicated the issue on my system and it is working now.

Thanks,
Sonali

Hello @Sonali_Mamgain,
Now the package mongodb-compass (1.18.0-1) on Ubuntu 18.04.2 LTS is working fine.
Thanks!

hello I use linux especially fedora 30 and is running correctly the only thing I did was download mongoDB compass on the official page and install by means of rpm guide me from this page
https://docs.mongodb.com/compass/master/install/

I am not able to connect to mongodb through compass. i am using 1.18.0 on windows.
It is giving me error- Could not connect to MongoDB on the provided host and port .

I assume you are using stable version
Are you able to connect thru shell?
May be firewall or antivirus software preventing connection thru compass

Hi Guys, I have installed my MongoDB Compass, but when i try to follow lectura: Documents: Scalar Value type, I watch on video the schema view on Compass, bu on my screen it does not appear. Any reason to that behavior?, should I have to do something in order to see the schema view? On my screen appears: Documents, Aggregations, Explain Plan and Indexes topics, but schema view does not.

Thank you.
Versión of my Compass Installation is: 1.19.12

regards.

Hi @Ignacio_68110,

You might be using MongoDB Compass Community edition which is not recommended in our course as it lacks some functionalities. Please download Compass 1.19.12 (Stable) version from the Download Centre.

Hope it helps!

If you have any other issue please feel free to get back to us.

Happy Learning :slight_smile:

Thanks,
Shubham Rajan
Curriculum Support Engineer

1 Like

use the cmd in your terminal
sudo dkpg -i “magodeb file name”
after successful installing you can search in the search box

2 posts were split to a new topic: How to enrol into M001 course