Link error in 4.4.0-rc9 on FreeBSD/aarch64

Hi, I’ve maintained the 3.4 and 4.2 ports of mongodb on FreeBSD. Currently I’m creating a port of 4.4.
I get the following link error. With I get the same error.

ld.lld: error: undefined symbol: boost::log::v2s_mt_posix::aux::default_attribute_names::message()

referenced by message.hpp:56 (/usr/local/include/boost/log/expressions/message.hpp:56)
build/opt/mongo/shell/dbshell.o:(_main(int, char**, char**))

Does this ring a bell to somebody? I can provide more info if needed.

Hi @R_K -

No, that doesn’t look like something I’ve seen reported before. MongoDB v4.4 does make rather extensive use of boost::log though. Could you provide some additional details? What version of FreeBSD? What toolchain and version is in use there? What does the SCons invocation used to build MongoDB look like?

I do note that it appears you are using the system version of boost rather than the vendored one. It would be interesting to know if the same error exists when using the vendored boost, just as an experiment.

Finally, please be aware that FreeBSD is not a supported platform, so we can’t really guarantee that this will be fixed in a timely fashion, or even necessarily fixed at all. Of course, if an easy and obvious fix is available that works on our other platforms of record, we will not have any objection to getting it merged.


1 Like