Libmongocrypt installation failed on Ubuntu

Hello, MongoDB!!

My company has been using below command to install libmongocrypt in docker image - but I noticed this command failed since last week Friday

sudo sh -c ‘curl -s | gpg --dearmor >/etc/apt/trusted.gpg.d/libmongocrypt.gpg’

mongodb/libmongocrypt: C library for Client Side Encryption. (

Error message was “gpg: no valid OpenPGP data found.”

Also, when l run curl command, it says
“/etc/apt/trusted.gpg.d/libmongocrypt.gpg: Permission denied”

I am wondering whether this is intended, or fixable

Hello @Sijoon_Lee
Welcome to the Community forum!!

There seems to be a change required in the curl command, and you can try the command with a --location parameter in the following way:

sudo sh -c ‘curl -s --location | gpg --dearmor

Also please let us know, if this helps you to install the libmongo packages?



Thanks, Aasawari, I tried on my local, it’s working
I believe it will also work for Docker image



sudo sh -c ‘curl -s --location | gpg --dearmo r/etc/apt/trusted.gpg.d/libmongocrypt.gpg’

My result is:
gpg: can’t open ‘/etc/apt/trusted.gpg.d/libmongocrypt.gpg’’: No such file or directory
gpg: dearmoring failed: No such file or directory
-s: 1: ‘curl: not found

How to fix this ?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.