LESSON 2: CREATING AND DEPLOYING AT ATLAS CLUSTER - doesn't create the project nor the cluster

This lab is divided into 3 parts.
In the first part, I started with the CLI by running:

atlas auth register

I created a new account, I used the verification code, and everything went well.

Then in the second part, I had to use their query to create the project MDB_EDU. Everything goes well again and it created 2 projects there in my organization. I know the IDE has a timer, however, I was unaware that this timer was also running between the steps. So before starting the third part of the lab, I left the pc to do something and when I came back it said my IDE timer ran out and I would have to start everything again.

Now, after the CLI part, I get the message:

Successfully logged in as <my email>
You don't seem to have access to any project
? Do you want to enter the Project ID manually? (y/N)

I ignore it (since there’s no existing project) and I click on Check. Everything goes well and I move to the second step.

Then in the second part, I had to use their query to create the project. But when I try to execute it, I got an error. So I go back to my org, I terminated the clusters, and then deleted the projects as I believe it was conflicting since it was trying to create a project that already exists. However, now when I run:

atlas setup --clusterName myAtlasClusterEDU --provider AWS --currentIp --skipSampleData --username myAtlasDBUser --password myatlas-001 | tee atlas_cluster_details.txt

I’m getting the following message:

You are already authenticated with an account (<my email>).
Run "atlas auth setup --profile <profile_name>" to create a new Atlas account on a new Atlas CLI profile.
Error: please make sure to select or add an organization and project to the profile: default

I already tried “atlas auth setup --profile <profile_name>”, I don’t know what is this default but I also tried to select my organization via its ID, I tried many things, I asked chatgpt and tried every single option it gave me and I’m out of options. I don’t have remaining emails to create another account and I can’t even delete my account to create another one because MongoDB doesn’t allow me to create another account with the email of the deleted one. I don’t know why this is not working since I have no projects there, I don’t know what is happening. This is so frustrating and I already lost so much time in here and I can’t move on with the course.

Does anyone know how to solve this issue?

1 Like

You have to logout (atlas logout) and then paste this command once again.

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.