Kafka connect weird date formatting issue

i am using kafka connector to get data from Mongodb but the dates in the messages look kinda weird.

instead of “created_at”: “1671463988665” i get “created_at”: {"$date": 1671463988665}
is there a setting to change this behavior? please advise on how to proceed.

You might want to try modifying the “output.json.formatter” property something like