Java script error

I am getting Java script error while restarting compass -“Object has been destroyed at Function…”
what I need to do now

1 Like

it seems to be a compass app error, sadly thought I had to restart my machine since only restarting compass won’t work.

You don’t need to restart the machine. Just kill all MongoDBCompass processes in the windows task manager, then you can restart compass.


I experienced this same problem today, and it what a little disconcerting as this is a Stable version.

@Peter_Jesper_79136 Thank You for the Solution.

I’m having the same issue and I think because I’m killing the program in the task manager is causing the program to give a JavaScript error message. I’ve only done this because I use to get an error connecting to the cluster but once I do connect I can’t filter through the data not sure whats going on here …

Hi Everyone,

Please download and install latest version i.e. 1.16.1. It has the javascript issue fixed.

Download from here. Thank you for the patience.


1 Like

I am having the exact same experience with 1.16.1 (Stable). This is the only version of Compass I have downloaded. Just downloaded yesterday, tried reinstalling, rebooting. Windows won’t let me uninstall.

When I kill the processes using task manager, I can start Compass. I use the connection parameters listed in the lecture notes, and get the “MongoDB is not running…” message. And all of the same problems repeat, including the Javascript error.

Hi tchrist,

Sorry for your experience. Please share the screenshot and the steps you did to connect through Compass.

Thanks, Kanika

  1. Opened compass, filled in the connection details per the lecture notes. Clicked connect, got this error:

  2. Closed and reopened Compass. Got Javascript error:

  3. Opened Task Manager, noted 3 processes still running:

  4. If I kill the 3 processes, I can start Compass successfully, but I am back at step 1 above.

Running version 1.16.0, even though the download link said it was supposed to be 1.16.1.


Sorry, I just checked the download page again. The version I am running was downloaded yesterday. That was 1.16.0. I see that 1.16.1 is available. Downloading now…

1.16.1 seems to have resolved the Javascript error. Now I just need to figure out why I still get the “MongoDB not running…” error.

1 Like

Hi tchrist,

Are you able to connect through mongo shell? Test it by running the following command:

mongo "mongodb://,," --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

If you cannot, check this post here.

If you can, then just make sure you have the paramters right and port 27017 is free to use. Let me know.


Looks like it was a firewall/proxy issue at my office. I was able to connect via browser but not Compass. From home, I am able to connect and all is well. Thanks for the help, sorry for the runaround!

1 Like