Issues Installing MongoDB 4.4 on Ubuntu Jammy 22.04

I am trying to install MongoDB 4.4 using the commands shown below.

curtis@curtis-virtual-machine:~$ sudo apt-get install gnupg curl
[sudo] password for curtis: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
curl is already the newest version (7.81.0-1ubuntu1.14).
gnupg is already the newest version (2.2.27-3ubuntu2.1).
0 to upgrade, 0 to newly install, 0 to remove and 133 not to upgrade.
curtis@curtis-virtual-machine:~$ curl -fsSL https://pgp.mongodb.com/server-4.4.asc | \
   sudo gpg -o /usr/share/keyrings/mongodb-server-4.4.gpg \
   --dearmor
curtis@curtis-virtual-machine:~$ echo "deb [ arch=amd64,arm64 signed-by=/usr/share/keyrings/mongodb-server-4.4.gpg ] https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/4.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-4.4.list
deb [ arch=amd64,arm64 signed-by=/usr/share/keyrings/mongodb-server-4.4.gpg ] https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/4.4 multiverse
curtis@curtis-virtual-machine:~$ sudo apt-get update
Hit:1 http://security.ubuntu.com/ubuntu jammy-security InRelease
Hit:2 http://gb.archive.ubuntu.com/ubuntu jammy InRelease               
Hit:3 http://gb.archive.ubuntu.com/ubuntu jammy-updates InRelease       
Hit:4 http://gb.archive.ubuntu.com/ubuntu jammy-backports InRelease     
Ign:5 https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/4.4 InRelease
Ign:6 https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/6.0 InRelease
Hit:7 https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/4.4 Release
Hit:8 https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/6.0 Release
Err:10 https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/6.0 Release.gpg
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A26B1AE64C3C388
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/6.0 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A26B1AE64C3C388
W: Failed to fetch https://repo.mongodb.org/apt/ubuntu/dists/jammy/mongodb-org/6.0/Release.gpg  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A26B1AE64C3C388
W: Some index files failed to download. They have been ignored, or old ones used instead.
curtis@curtis-virtual-machine:~$ sudo apt-get install -y mongodb-org=4.4.25 mongodb-org-server=4.4.25 mongodb-org-shell=4.4.25 mongodb-org-mongos=4.4.25 mongodb-org-tools=4.4.25
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package mongodb-org-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  mongodb-org-database-tools-extra:arm64 mongodb-org-database-tools-extra mongodb-database-tools:arm64 mongodb-database-tools

Package mongodb-org-shell is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mongodb-org-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mongodb-org-mongos is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mongodb-org is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Version '4.4.25' for 'mongodb-org' was not found
E: Version '4.4.25' for 'mongodb-org-server' was not found
E: Version '4.4.25' for 'mongodb-org-shell' was not found
E: Version '4.4.25' for 'mongodb-org-mongos' was not found
E: Version '4.4.25' for 'mongodb-org-tools' was not found

What can I do to get version 4.4 running on my version of Ubuntu?

Ubuntu 22.04 is not a supported platform for MongoDB 4.4. Ubuntu 20.04 is the most recent version to support it.

Alternatives to run MongoDB 4.4 on Ubuntu 22.04 would be to run a container or a virtual machine.

https://www.mongodb.com/docs/v4.4/installation/#supported-platforms