Issue when installing locally on Windows 10

The MSI installer ask if we want to install MonboDB as a service. Then, doesn’t matter what value are entered it always end the following error message :

The domain, user name and/or password are incorrect. Remember to use “.” for the domain if the account is on the local machine.

it seems also described here :
https://superuser.com/questions/1403332/invalid-domain-user-password-while-installing-mongodb-on-windows10

And here :
https://stackoverflow.com/questions/52092528/invalid-domain-user-password-while-installing-mongodb-on-windows10

1 Like

Please try your Windows username/password

It works but I don’t get why I should give those sensitive data to MongoDB and why other DBMS such as MySQL doesn’t need it to install :confused:

5 Likes

horrible, I want days where i could install software without giving so much information! For free edition? seriously mongodb, I don’t even have my password setup in windows it is PIN! What a horrible UX, made account just to vent out

Hello @Ruth_H_Gilbreath, and welcome to the MongoDB Community forums! :wave:

The post you replied to talks about setting up mongod to run as a service. You are providing that info to the Windows OS to run the service. This is a Windows thing, not MongoDB. Note that this information is not sent to either MongoDB or Microsoft. The only time you’re providing information directly to MongoDB is if you’re creating an Atlas account, but then you’re not installing MongoDB on your Windows system in that case.

You can run MongoDB on Windows without setting it up as a service. Doing this however means that you have to manually run the mongod command before using the database.