Issue in installing mongo in MAC OS

Getting error when trying to open mongo in MAC OS


Can you check if mongod is running and try to ping

1 Like

@007_jb How to check that?

@007_jb: I am getting response from ping but mongod & mongo both are still not working

  1. Check if mongod is running:
    ps -ef | grep "[m]ongo"
  2. Ping that IP from the terminal:
1 Like

Getting this in mongod :frowning:


Run the first command I gave you and let’s see the result. Don’t run mongod.

1 Like

Yes, I tried that

Try: ps -ef | grep mongo

1 Like

Ok. Mongod is definitely not running.

Test the port on your browser and let’s see the result:
It should look like this:

yes, it is allowing

I should have noticed the error message :man_facepalming:

You need to create the directory /data/db and give it the right permissions. Was this not explained in the lecture? I didn’t take this particular course that’s why I’m asking.

no, it was . not explained. Can you please suggest some url

Website that explains what exactly?

@Gaurav_88483 you mean how to create a directory?

1 Like

Hi @Gaurav_88483,

Mongo is throwing an error because there is no mongod instance running on your system.

The logs in the screenshot says the directory for the DB path is non existent. This is strange because if you are launching the default mongod instance running on port 27017 then WiredTiger Storage Engine creates that for you.

Can you please share the command that you used to launch the mongod instance along with the output ?

Shubham Ranjan
Curriculum Support Engineer