Installing mongodb over Ubuntu 22.04

For those who only need the shell and some tools like mongodum/restore, you just have to install those two packages witch are included in the officiel mongo repo:

sudo apt install mongodb-mongosh-shared-openssl3 mongodb-org-tools

yes its correctly worked I search lot of time to solve this problem.

Any updates? Almost 3 months from Ubuntu 22.04 release…

7 Likes

We found this really annoying but solved the problem by witching to AWS DocumentDB. Now everything works again under 22.04, we save some money by handing off the whole replication problem to AWS, and our searches are faster to boot. If the real MongoDB had gotten its act together sooner we would never have known.

4 Likes

This doesn’t worked for me, I have installed libssl3 but doesn’t work with libssl1.1.
I already have 3 days finding a solution but nothing

:warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning::warning:

Download the libssl1.1 package from https://ubuntu.pkgs.org/20.04/ubuntu-main-amd64/libssl1.1_1.1.1f-1ubuntu2_amd64.deb.html

and install it using gdebi or dpkg. Then proceed installing mondodb using sudo apg-get install

2 Likes

Tried everything but no luck .Feel like the Mongo team does not want to fix it as the CE is a competitor to their Atlas … Any ideas for alternatives?

Do we have an official release yet?

Are we there yet? :laughing: Sadly not…

1 Like

Hi, any updates? about this issue when is the release expexted?

Worked, thanks @Geoffrey_Mungai!

It is working now. My mistake was tring to install from the “software install” .
first downlod the lib from here
http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2_amd64.deb
next open terminal and to to the download lib location then
sudo dpkg -i libssl1.1_1.1.1f-1ubuntu2_amd64.deb

thanks to @Geoffrey_Mungai

1 Like

for me below was worked.

echo “deb Index of /ubuntu focal-security main” | sudo tee /etc/apt/sources.list.d/focal-security.list
sudo apt-get update
sudo apt-get install libssl1.1

Finally! Below Solutions worked for me

It is because of the missing dependencies mongodb not installing on ubuntu 22.04.
The main reason is the missing of libssl1.1 dependency. So we need to install it seperately.

1.sudo apt install dirmngr gnupg apt-transport-https ca-certificates software-properties-common

2.echo "deb http://security.ubuntu.com/ubuntu impish-security main" | sudo tee /etc/apt/sources.list.d/impish-security.list

3.Go to root user sudo -i then paste this wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2_amd64.deb

4.apt update

5.apt install libssl1.1

6.wget -qO - https://www.mongodb.org/static/pgp/server-5.0.asc | sudo apt-key add -

7.echo "deb [ arch=amd64,arm64 ] https://repo.mongodb.org/apt/ubuntu focal/mongodb-org/5.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-5.0.list

8.apt update

9.apt install -y mongodb-org

The latest version of mongodb will be installed
To start it

1.systemctl enable mongod

2.systemctl start mongod

In case MongoDB doesn’t start run the command below to reload.

systemctl daemon-reload

1 Like

I have been using ubuntu in 20.04 and now I want to use it in 22.04 but the actual support of mongodb for Ubuntu 22.04 isn’t released yet. Any reason why the delay of the release for Ubuntu 22.04.

I was able to easily install mongosh on Linux Mint 21. It should be the same instructions for Ubuntu 22.04:

sudo curl https://www.mongodb.org/static/pgp/server-6.0.asc | gpg --dearmor >/usr/share/keyrings/mongodb-key.gpg

echo "deb [ arch=amd64,arm64 ] https://repo.mongodb.org/apt/ubuntu jammy/mongodb-org/6.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-6.0.list

sudo apt update

sudo apt install mongodb-mongosh
1 Like

Nice workaround!! I’ll take it. Sounds like you’ve understood the impacts of the replaced dependencies.

Hi,
This worked for me.
But my concern is I am not able to open mongodb shell using in terminal i tried both the commands,
mongo : showing Command ‘mongo’ not found
mongodb : showing this error.

Please let me know how to use mongodb shell in ubuntu 22.04.
I checked the status of mongodb its showing active.

Thanks,
Sandip R.

The mongo command line shell is no longer available in MongoDB 6.0. You want to use the newer mongosh shell. It should have been installed when you installed MongoDB, but if not you can download it separately.

The screenshot shows you ran the mongod command. This is the MongoDB database engine process. Since the process was already running using the defaults, a second instance could not be started and should have failed with a message in the logs similar to Address already in use.

Do you have an estimation when mongo v6.2 will be released?