Installing MongoDB-org on Raspberry Pi (bullseye) doesn't work

Hi,
There are 2 mongodb packages, one is from Ubuntu and other is from mongodb-org. I want to install mongodb-org on a fresh RaspberryPi 4 (bullseye). I follow the instruction on the official site (https://www.mongodb.com/docs/manual/tut … on-ubuntu/) , but I always get this error:
E: Unable to locate package mongodb-org

I followed those steps:

wget -qO - https://www.mongodb.org/static/pgp/server-5.0.asc | sudo apt-key add -
OK
echo "deb [ arch=amd64,arm64 ] https://repo.mongodb.org/apt/ubuntu focal/mongodb-org/5.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-5.0.list
sudo apt-get update
sudo apt-get install -y mongodb-org
..
E: Unable to locate package mongodb-org

I don’t get any error from other steps. Only from installation step.

I also tried Debian package:

echo "deb http://repo.mongodb.org/apt/debian buster/mongodb-org/5.0 main" | sudo tee /etc/apt/sources.list.d/mongodb-org-5.0.list

Still no success.
How can I install it?

Are you running 64bit linux?

What is uname -a showing?

No :slight_smile:
I was not running 64-bit Linux.
I installed 64-bit and now I was able to install mongodb.
Thanks.

1 Like