Installing Mongodb on Rocky Linux 9 - AArch64

I have a VPS AArch64 server using Rocky Linux 9.
I’m following the tutorial here Install MongoDB Community Edition on Red Hat or CentOS — MongoDB Manual to install mongodb.
I have create the repo file

name=MongoDB Repository

The aarch64 repo is there. MongoDB Repositories
But, when I run sudo yum install -y mongo-org I get this message

I tried doing the same on another AArch64 server using Rocky Linux 8 and it worked fine.

Am I doing something wrong that it isn’t working on Rocky Linux 9?
I hope someone could help me with this.

Hello @Eustachio_N_A ,

Welcome to The MongoDB Community Forums! :wave:

As per the documentation mentioned below

As of now, we are supporting Rocky 8 on arm64 hence you were able to install and work on that successfully.
Rocky 9 is supported on x86_64 and not on arm64 architecture yet, therefore the error.

Please keep an eye out on the production notes for any additions to this list of supported platforms.


1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.