Installation issue of compass in Windows 7 32 bit

I tried to install compass using given link but it failed to install in my system. My system is windows 7 32 bit.

Hi @Satyajit_41184,

I am sorry but currently Compass does not support 32-bit systems. It only supports 64-bit.

However, you can continue the course without any issue. You can use Mongo Shell for getting the results for Labs except just one Lab: Scavenger Hunt Part 3. Rest all can be done without Compass.



I am not able to install mongodb-compass in my system. Installation process starts but nothing happens after that. My system is 64 bit windows 7. Please help.

Thank you!

Hi @Pavan_35600,

Please try downloading 1.18 Beta version of Compass. You can refer to the following screenshot to check the exact version:

Please let me know, if it helps.


Hi @Sonali_Mamgain

I tried .exe file, it worked. Thanks for your help.

Yes, came to say that. The MSI fails. Use the .EXE instead. That should work fine.

Hi Pavan,
Select Windows 64-bit (7+), basically it is exe file.
It will work as expected.

@Nitesh_Nandan_49326, @Francisco_Bloise_14065

Thanks guys. Yeah, it worked.