Index suggestions disappear before I get a chance to view them

Hi all,
I keep getting index suggestion alerts for my cluster, and when I check the Performance Advisor, there is nothing there.

I’ve used Performance Advisor before to set up indices based on such alerts, but in the past few days my email inbox is flooded with index suggestion alerts, and no corresponding index suggestion in the Atlas UI. I think it’s because the suggestion gets “revoked” quickly - the alert gets opened then closed within just a few minutes, and I get 2 emails each time.

I have some scheduled tasks that do heavy lifting - my guess is that as these run, they trigger index suggestions, but those suggestions get closed/revoked once the task is done and the traffic reverts to normal. Completely removing the suggestions from the UI doesn’t seem like the best idea? I’ve tried to load performance advisor immediately after the task runs but I can’t catch them.

Some improvement ideas for this feature:

  • Include the actual index suggestion in the email alert, instead of just directing the user to performance advisor
  • Don’t completely revoke index suggestions in a way that makes them inaccessible via UI - flag them as ‘stale’ maybe?

Any ideas on how to access these disappearing suggestions so I can act on them?

Hi @Sitati,

Thank you for your question and I’m sorry you’re experiencing this problem. We recently rolled out an update to Atlas to make the Performance Advisor alerts more deterministic. However, if you’re seeing the opposite behavior within the last few days, we may need some additional investigation. Could you please open an Atlas support case including your project ID so we can further investigate?

Thank you,
Frank

I don’t think my plan lets me raise support cases, I get a screen saying “not enabled for support” when I try to raise a case.

This alert spam is still going on all the time, and it’s clearly some flawed logic.

I tweaked the alert so it should only come if the conditions for index suggestions are consistent for 10 hours, but I still get a flood of emails showing the alert condition flipping between OPEN and CLOSED every few minutes, which doesn’t make logical sense.

I’ll email this to the support email, could you help in getting this followed up on? Looks very much like a bug report rather than a user support case.