I'm facing this error while connecting with the compass with atlas

I don’t understand this solution. Can you help?

You need to add your IP to the Atlas access list. Try this and if the error persists, let us know here.

even I have added the IP address. although the error is not solved. What can i do?
the error comes while i connect the mongodb compass through atlas cluster connection string

I experience the same problem. My IP-address is whitelisted in the Network Access settings, plus I added 0.0.0.0/0 to allow all IP-addresses.
Unfortunately this did not help, I still can’t connect to the cluster.
mongosh gives me the same error btw.

What to do?

EDIT:
I am not sure it it is related, but I also can’t browse the collections. In the web-UI it shows this error:
“An error occurred while querying your MongoDB deployment.
Please try again in a few minutes.”
(this persists for some hours now)

Try without tls=true to validate.

1 Like

Thanks for your answer.

In my case the problem is that the database (free M0) got throttled due to a performance-issue with a query and is not reachable until it is enabled again.

The error message is misleading, but support is responsive.

1 Like

I have added the IP address. but the error is not solved. what to do now?

1 Like

What error does it return?

1 Like


I have added ip address but still getting this error.


still getting error

Are you using an M0 cluster? Have you verified whether it is the same case as above?

yes i am using M0 cluster


what to do in this case?

Do the IP Addresses still show as pending as they do above?

There are cloud issues on shared tiers, so this could be causing the issues with the IP Address settings not updating.

You can monitor it here, I’d wait for this to be resolved and try to add your IP address and connect again.


It still shows pending

Yep, looks like this is because of the Atlas issues that are going on currently.

I am facing this error , anyone please help me please

Is there anyone active , i am trying to resolve this please help me

2282624:error:10000438:SSL routines:OPENSSL_internal:TLSV1_ALERT_INTERNAL_ERROR:…..\third_party\boringssl\src\ssl\tls_record.cc:592:SSL alert number 80

I am facing this issue while trying to connect with compass, and i have my IP address connected on the Atlas