I cannot connect my cluster to mongoDB compass

this is the error message

connection <monitor> to closed

how do i fix it?

Have you whitelisted your IP?
Something is blocking your connection
Did you try from another location/network or your mobile hotspot
Are you using any VPN,proxy,firewall etc?

1 Like

I did not whitelist my IP, and I don’t understand what you mean by if I tried another location. Lastly I’m not using any vpn or proxy


  • you haven’t set Atlas to permit connections, thus it drops your connection
  • or Atlas is fine, but a VPN, Proxy, Firewall or a company’s program denies you to connect to Atlas.

To check Atlas side,

  • login to your Atlas account and head to your organization, then select your project/cluster.
  • get to “Network Access” in the “Security” link on the left.
  • Click “Add an IP address” and add your current IP, or allow access from “anywhere”
  • Also create a user in “Database Access” in the same section, if needed.

If you still cannot connect, then try a different PC or different internet.


I allowed access fro anywhere and it worked

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.