I can not connect my mongodb compass with my cluster

querySrv ENODATA _mongodb._tcp.jvuwithjesus.ygys3.mongodb.net

Are you using a mongodb+srv:// connection string? If you are, it’s possible that the DNS servers of your internet service provider can’t resolve SRV records. Try switching your DNS to 8.8.8.8 and 8.8.4.4 (Google DNSs) and see if that works.

This is my connection string : mongodb+srv://hellojesus1:qNgKFnnczkiIShHP@jvuwithjesus.ygys3.mongodb.net/jesusdatabase?retryWrites=true&w=majority
I still have error:
querySrv ENODATA _mongodb._tcp.jvuwithjesus.ygys3.mongodb.net

The connection string is correct. You have to

I tried to switch to you dns but It still doesn’t work.
It still has same error.
Is there any other way?
Please help !!!

Did you try long form of string instead of srv?

1 Like

Please post a screenshot of the DNS configuration you tried.

Hi Steevej,
Can you show me the screen shot of google dns connection.
I really don’t know where I replace google dns.
Please Help!!!

I used this connection string:
mongodb+srv://hellojesus1:qNgKFnnczkiIShHP@jvuwithjesus.ygys3.mongodb.net/jesusdatabase?retryWrites=true&w=majority
but it doen’t work.
Please help!!!

Check this link

Long form of connect string you can get from your Atlas account.Choose old version of shell

Is password given in your connect string correct?
I am getting different error

2022-05-21T16:43:41.648+0530 I NETWORK [js] Marking host jvuwithjesus-shard-00-02.ygys3.mongodb.net:27017 as failed ::
caused by :: Location40659: can’t connect to new replica set master [jvuwithjesus-shard-00-02.ygys3.mongodb.net:27017],
err: Location8000: bad auth : Authentication failed.

1 Like

This is my creen shot of network ip:

IP Address Comment Status Actions
8.8.8.8/32 Active EDIT DELETE
0.0.0.0/0 (includes your current IP address) Active EDIT DELETE
8.8.4.4/32

This is not your DNS server setting. It is your Atlas network access list. Go to the Google Developers link provided by @Ramachandra_Tummala and follow the instructions to change your DNS settings.

Alternatively, do as suggested by @Ramachandra_Tummala and use the Long form.

Hi Steevej,
I already connected your DNS settings 8.8.8.8 and 8.8.8.4 but It did not work and I could not use my internet to access any websites.
Is there other ways?
Please help!!!

Did you do the dns settings on your laptop/pc from network-adapter?

Did you try long form(old style) connect string method?
From your Atlas account choose connect to shell and select old shell version in drop down
What other options you see in your Compass?
Does fill individual fields option exist?

It is 8.8.4.4 and please help us help you by providing

I do not see where you specified 8.8.8.8 or 8.8.4.4

That’s the correct DNS. But your previous screenshot shows that you are not using this Wi-Fi network interface. You have to set the DNS on the network interface you are using.

Hi Steevej,
I really don’t understand what you mean about network interface. Can you give an example or explainations about it.
Thanks for your time.
Please help!!!