I am not being able to export my Data base (I do not have Compass install due to exercise purposes)

Hi Guys, has anyone had the same scenario that I am having?
I have a database with two collections and when I try to export it I receive a message with exported 0 records.
I am rarely new- any suggestions will be much appreciated-
I have tried as examples: mongoexport --collection=events --db=reporting --out=events.json or mongoexport -d name_of_database -c name_of_collection -o name_of_file.json.

It should work
What is your mongoexport and mongodb version?
Show us db with collections and full mongoexport log


Hope that suffices.

Regarding logs would you mind being a bit specific? Hehe I believe I understand partially

Where is the reporting db?
I was asking for mongoexport log from your terminal where it showed 0 rows exported

So under movies db do you have movies collection?
Show output of below commands from db
use movies
show collections

No, I believe that is the issue.
I created a new one it worked.
I mean a database without a collection is not really functional?
Thanks anyhow for helping out