I am getting an error when trying to import a JSON file to MongoDB via Compass

I am on Windows 10. I recently obtained a large JSON file (200 MB) via webscraping, and I am now trying to import the file to MongoDB using Compass Community via the import data button. However, whenever I try to import the file, I get the following error:

Unexpected token l in JSON at position 0 while parsing near 'l

Here are the first few lines of the JSON file I am trying to import:

    "bands": [{
            "activity": "Split-up",
            "bandMembers": ["https://www.metal-archives.com/artists/Jon_Powlowski/760544", "https://www.metal-archives.com/artists/Ruben_Martinez/760545", "https://www.metal-archives.com/artists/Greg_Eickmier/416646", "https://www.metal-archives.com/artists/Nedwob/471955"],
            "bandName": "A // Solution",
            "country": "United States",
            "dateAdded": "2018-08-04",
            "genre": "Crust Punk/Thrash Metal",
            "label": {
                "labelName": "Voltic Records",
                "labelUrl": "https://www.metal-archives.com/labels/Voltic_Records/47794"
            "location": "California",
            "lyricalThemes": "N/A",
            "releases": [{
                    "numReviews": 0,
                    "releaseName": "Butterfly",
                    "reviewAverage": null,
                    "type": "EP",
                    "url": "https://www.metal-archives.com/albums/A_--_Solution/Butterfly/723154",
                    "year": "1989"
                }, {
                    "numReviews": 0,
                    "releaseName": "Things to Come",
                    "reviewAverage": null,
                    "type": "EP",
                    "url": "https://www.metal-archives.com/albums/A_--_Solution/Things_to_Come/723155",
                    "year": "1995"
            "similarArtists": null,
            "url": "https://www.metal-archives.com/bands/A_--_Solution/3540442600",
            "yearFormed": "N/A",
            "yearsActive": "N/A"
        }, {
            "activity": "Active",

Does anyone have an idea on how I can fix this error?

EDIT: I just got this error after restarting compass:

Unexpected token : in JSON at position 0 while parsing near ': null,

Is this error related at all to the other one?

Can you post the whole JSON file here or a link to it so we can download it and test it?

Here is a link to the dropbox

I am having the similar problem. I try to import Json file using MongoDB Compass, and getting this error:

I tried several json files, but it never worked out. Also, importing file through Studio 3T does not work.

Any idea or solution for this issue?

Json files are here:
forge-rcdb.nodejs/resources/db at master · Autodesk-Forge/forge-rcdb.nodejs · GitHub

Object(…) is not pure JSON.

Who ever produced that JSON file did not do it correctly. If you try to export a collection, from Compass for example, you will see that the object id is coded as

  "_id": {
    "$oid": "626c18a3d880647a888888ff"

rather than

"_id" : ObjectId( "626c18a3d880647a888888ff" )

You would need to modify you files to use the correct format.