How to install mongodb 6.0 on Ubuntu 22.04

Hello! I try to install mongoDB community server 6.0 on Ubuntu 22.04. Belows are my installation process.

sudo apt-get update
echo "deb impish-security main" | sudo tee /etc/apt/sources.list.d/impish-security.list
sudo apt update
sudo apt install libssl1.1  --> libssl1.1 is not installed!

wget -qO - | sudo apt-key add -
echo "deb [ arch=amd64,arm64 ] focal/mongodb-org/6.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-6.0.list

But libssl1.1 is not installed and brings the errors when executing the installation.

sudo apt update
sudo apt install -y mongodb-org

Belows are the error messgaes.

mongodb-org-mongos : Depends: libssl1.1 (>= 1.1.1) but it is not installable
 mongodb-org-server : Depends: libssl1.1 (>= 1.1.1) but it is not installable
 mongodb-org-shell : Depends: libssl1.1 (>= 1.1.1) but it is not installable

So I downloaded the installation deb file from the site and execute it. But the same errors are thrown. Any reply will be thanksful. Best regards

1 Like

Ubuntu 20.04 is the latest supported Ubuntu.

Keep an eye on

Use the supported platform or you can run it in Docker.

1 Like

Hi Guys, any update on what 22.04 will be supported?

1 Like

hey guys,

the following allowed me to run version 6 on ubuntu-22.10-in-a-docker-image. so in theory it should work on a real installation too.

in addition to the steps you followed, do this first:

sudo dpkg -i libssl1.1_1.1.1-1ubuntu2.1~18.04.20_amd64.deb

As long as they do not break installed things, “archived” packages should always install and run without a problem. that is what happened in these lines.

Yet, keep in mind that, if you break things, the responsibility is yours because MongoDB Community 6 is not yet supported on Ubuntu 22 (is the enterprise version supported? I did not try).

PS: I found the package here: Index of /ubuntu/pool/main/o/openssl . there are a few others so check they are applicable instead of the one I use.

this also works:

echo "deb focal-security main" | sudo tee /etc/apt/sources.list.d/focal-security.list

With this one, it will not even require you to know what to install. it will fetch “1.1.1f-1ubuntu2.16” for amd64. (my other answer used ubuntu2.1~18).