Having issues with mongodb trigger over sending http request

I am having issues sending http request to my local machine when trying to use the trigger + function service in mongo atlas, I have tried using both fetch api and axios but still getting some blocker, here’s the last one I tried writing but still not working:

maybe there’s something I am missing

Hey @Abolaji_Disu,

Welcome to the MongoDB Community!

From my understanding, it seems that sending a request to the localhost API is not feasible, as it is not accessible in the cloud and cannot be accessed by MongoDB Atlas Functions. I hope this clarifies your doubts.

However, to further assist you, may I ask what specifically you are trying to accomplish?

Best regards,

Yeah @Kushagra_Kesav thanks, I finally figured it won’t work, I was basically trying to test mongo trigger functions to a local server however it didn’t work out. I had to deploy my backend code on a remote server and provide the endpoint then it worked just fine,