Handshake error: unable to saslStart conversation with mongosqld

I have mongodb 4.4.0 running on a linux machine, as well as mongosqld version 2.14.2. I am trying to connect from a windows machine. The db is set up with auth. Here’s the command currently being used to start the mongosqld:

/bin/mongosqld --addr= --mongo-authenticationMechanism SCRAM-SHA-1 --mongo-authenticationSource my_database --auth --mongo-username=user --mongo-password=XXXX

When the windows user tries to connect, I’m getting this error from the mongo odbc daemon:

connection accepted from X.X.X.X:18865 #1 (1 connection now open)
[conn1] handshake error: unable to saslStart conversation 0: unable to execute command: (AuthenticationFailed) Authentication failed.

I cannot seem to find any solution to this, and so many of the posts don’t specify where you are supposed to install things (the connecting workstation or the server). I’ve tried the other 3 authentication mechanisms, same error.

Please let me know if you need any more info and if you have any idea as to how to resolve this?

FWIW, if I remove the auth on the mongo daemon and the odbc daemon, the windows machine can connect just fine.

Thanks for any help,

I was facing the same issue, the following work around resolved the issue:
I just had to replace ‘%40’ with ‘@’ in the password.
There could be other reasons as well, but this one worked out for me.


Hi I tried using $ in password. I am able to map the schema in mongosqld but when configurating to mongodb odbc driver I am facing an error Handshake error: unable to saslstart conversion