GraphQL api endpoint query does not match query in GraphiQL in Realm UI

Hi,
I just renamed an input field in a custom resolver I have in Realm.
The query works perfectly fine if I use it through the GraphiQL explorer in the Realm UI.
But if I use the api endpoint to reach the GraphQL api, the schema seems to not be updated.
The query gives me an error saying that this new field name does not exist. And I can keep using the old, non existing, input field.

Query docs in GraphiQL

Query in GraphiQL

Same query through /graphql endpoint (note error “In field “articlenumber”: Unknown field.” )

Is the schema perhaps cached? I found information about something similar here https://docs.realm.io/sync/graphql-web-access/how-to-use-the-api but, Im not using realm sync and the endpoint suggested does not seem to exist on my graphql endpoint.

How do I make the schema also be updated for external api calls?

Best Regards

Hi,
An update.
We deploy the same app in a dev and prod version.
The problem described above only occurs in our dev app.
The production app reacted properly to the changes of the field name, whilst the development app did not.

Closing up on release of these apps, so any help is much apprecieated.
Thanks!

Hi,
Another update.
Now, one week later, the query works fine in the dev app aswell.
I guess the schema cache got cleared by itself or something.
I would still like to know what caused this delay, and also, how in the future we could handle it manually to avoid having to wait a week for it to automatically get solved?

UPDATE: Any changes being made, now results in this issue. Ive had to delete and redeploy the app in order to be able to use any changes. Could you please inform me of how this cache can be cleared without having to create a new app on every little change made?

Thanks!

Hi!

Did you deploy changes to your app via GitHub? There appears to be a minor caching issue for apps deployed via GitHub that we are currently resolving. A temporary workaround is to deploy via the UI if possible to invalidate the cache if possible (any change would suffice here and you can keep your current GraphQL changes)

1 Like

Hi! Thanks for the information.
Deploying through the UI worked.
Is there any estimation when this fix will done?

No problem!
The fix should be out by the middle of next week. I will provide an update if we can get this out sooner or if I have a more accurate estimate.

Regards,
Kush

3 Likes

Hi @clakken!

This fix should be live in production now. Please feel free to let us know if you notice any strange behavior again. Thank you for pointing this out!

Regards,
Kush

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.