Github Auto Deploy deployed everything except custom resolvers in GraphQL

Hi, anyone has worked out the github auto deployment with Realm App? It looks like the documentation is a little bit outdated, such as it mentioned --for-source-control option, which is not working any longer.

And the key issue is after implementation, the process looks fine, but custom resolvers of graphql won’t be deployed. Even I have export the realm app from UI, and then deploy them into another app with github. Everything deployed except the custom resolvers. No error in the log. No trace to find any info.

Hey Lawrence, we don’t have this at the moment, but you can still use Firebase Auth with Realm using JWT Auth (or any other external auth service that provides Twitter OAuth).

HI @Leon_Guan .

I’m having the same issue, and it’s a bit worst, because when I manually create the Custom resolvers on the UI it generate a config/deployment draft and after I approve the draft it merges to Git which then triggers the deployment and removes the manually created Custom Resolvers.

Did you find a solution??


I have resolved the issue at my end.

The root cause is version of realm-cli , in their docs, v1 has been used, but in their guides when enable the auto deployment, v2 has been used (which is in beta stage).

We need to stick with v1 version, which is stated in their docs, just don’t follow the guides when enable the feature. The v2 version has many issues, such as the app id need to be presented, and the custom resolver not get synced, etc. The V1 version at least worked better with git integration.

1 Like

Thanks, @Leon_Guan1 .

I end up using the realm-cli and it worked as you said.

Thank you

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.