Getting strange message after feedora upgrade

HI, I have MongoDB on a fedora 31 that I run manullay using the following command which worked fine

/opt/mongodb/mongodb-linux-x86_64-2.2.7/bin/mongod --dbpath /home/data/db

I upgraded to fedora 32, after upgrade process finished fedora start gets blocked as you can notice in the snapshot. can you please tell me why i am getting this as i have never enabled mongodb at startup, thanks

and it freezes the screen and cant do anything

Welcome to the MongoDB Community Forums @Salamm_Elias !

MongoDB 2.2 server was first released in August 2012 and reached end of life in Feb 2014. I strongly recommend upgrading to a supported version of MongoDB server (currently 4.0 or later) for support on modern operating systems. Additionally, Fedora 32 is end of life since May 2021 – currently only Fedora 34+ is maintained.

/opt/mongodb/mongodb-linux-x86_64-2.2.7/bin/mongod --dbpath /home/data/db

If you start the mongod process as root or another user, the permission for data files will likely be incorrect if you try to start MongoDB as a service. There should be more information on startup errors in your MongoDB log files.

i have never enabled mongodb at startup

I’m not sure why this might have changed, but you should be able to prevent the service running at startup with a command line like:

 systemctl disable mongod.service

The Ask Fedora forums may be a better source of advice specific to managing Fedora services and upgrades.


Fixed as disabled start at startup

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.