Full Document Before Change

My trigger is set to receive the full document before change.

However I’m not receiving the property fullDocumentBeforeChange in my Realm function.

My Linked Data Source has no collections in it, and I don’t see where I could add them. Maybe this is the issue? How do I add collections to the configuraton below?

I managed to solve it by running the following command through mongosh:

db.runCommand({ collMod: "collection_name", recordPreImages: true })

After running it it appears on the list above.

Sadly I have to run it manually for every collection of every database that I need preimages enabled. This should also be configured through Realm config files.