Fix FeatureCompatibilityVersion

Hi Team,
There is an issue I am stuck in.

I needed to upgrade a replica set of 3 servers from 3.6 to 4.2, upgrade to 4.0 went ok. On primary of the RS post upgrade to 4.0, I missed to set FeatureCompatibilityVersion to 4.0 and proceeded to upgrade to 4.2, now I am getting this error when trying to start the service:

2021-12-24T10:46:48.716+0000 F CONTROL [initandlisten] ** IMPORTANT: UPGRADE PROBLEM: Found an invalid featureCompatibilityVersion document (ERROR: BadValue: Invalid value for version, found 3.6, expected ‘4.2’ or ‘4.0’. Contents of featureCompatibilityVersion document in admin.system.version: { _id: “featureCompatibilityVersion”, version: “3.6” }. See https://docs.mongodb.com/manual/release-notes/4.2-compatibility/#feature-compatibility.). If the current featureCompatibilityVersion is below 4.0, see the documentation on upgrading at https://docs.mongodb.com/manual/release-notes/4.2/#upgrade-procedures

On other 2 servers, it all went well. So as of now only 2 members are up and running on 4.2 and 1 being down.

Can you please suggest how to fix this problem. I could not find anything related to this. Let me know in case any info is needed from my end.

Thanks,
Rajeev

Hi @Rajeev_Vishal,

I assume you have probably worked out a solution by now, but I expect you would have been able to:

Alternatively, if you managed to correctly upgrade two of your replica set members to 4.2 and somehow missed updating the remaining member you could resync that member of your replica set to get it consistent.

Regards,
Stennie