filterBatch attribute is coming empty when ran listCollections command

Hi Team,

 I am looking to fetch the options set for the collection by using the c++ libmongoc driver of version 1.0 .
 The code i used to ran the database command of listCollections is below.
 // {listCollections: 1 ,filter:{"name":"mycol"}}
                                bson_t statement;
                                bson_t filterDoc;
                                
                                mongoLib.fp_bson_init (&statement);
                                mongoLib.fp_bson_init (&filterDoc);

                                
                                mongoLib.fp_bson_append_utf8 (&filterDoc, "name", -1, table_name, -1); 

                                mongoLib.fp_bson_append_bool(&statement, "listCollections", -1, "1");
                                mongoLib.fp_bson_append_document(&statement, "filter", -1, &filterDoc);

                                if (mongoLib.fp_mongoc_database_command_simple (adminDatabase, &statement, NULL, &reply, &error)) {
                                    size_t length = 0;

                                    char *output = mongoLib.fp_bson_as_relaxed_extended_json(&reply, &length);
                                }

The output i got is,

(gdb) p	output
$2 = 0x55555712db00 "{ \"cursor\" : { \"id\" : 0, \"ns\" : \"admin.$cmd.listCollections\", \"firstBatch\" : [  ] }, \"ok\" : 1.0, \"$clusterTime\" : { \"clusterTime\
" : { \"$timestamp\" : { \"t\" : 1701173864, \"i\" : 1 } }, \"signature\" : { \"h"...

Here the firstBatch should have the options field. However getting the empty error \"firstBatch\" : [ ]

And when the same is executed in the mongo shell I can see the firstBatch with options.

db.runCommand(    {       listCollections:true ,filter:{"name":"mycol"   }} )
{
	"cursor" : {
		"id" : NumberLong(0),
		"ns" : "nov.$cmd.listCollections",
		"firstBatch" : [
			{
				"name" : "mycol",
				"type" : "collection",
				"options" : {
					"changeStreamPreAndPostImages" : {
						"enabled" : true
					}
				},
				"info" : {
					"readOnly" : false,
					"uuid" : UUID("11d9a351-f3ae-4079-9afb-5cd2ac31525b")
				},
				"idIndex" : {
					"v" : 2,
					"key" : {
						"_id" : 1
					},
					"name" : "_id_"
				}
			}
		]
	},

Is there anything im missing in the C++ side that firstBatch is not been fetched?

any help on this would be much appricated.