Failed to sign up: authentication via 'local-userpass' is unsupported + MongoDB Realm

I’m following the Task Tracker tutorial. The app is spooling up on my ios emulator displaying the login/registration page. When I try to register a user (I’ve even tried just straight up login), either way I receive this error message: Failed to sign up: authentication via ‘local-userpass’ is unsupported

Within the Atlas UI I’ve made certain that my access rights have been set to anonymous thinking I could get started without signing in (just to see if I can access further into the app).

I’ve reviewed the finished code on GitHub, as well as reviewing the tutorial code and everything looks correct.

Think is my first Realm experience any help is much appreciated. Anyone have any ideas? Has anyone else run across this? I saw an earlier post similar to this, but apparently the issue resolved itself, so I couldn’t gain any ideas from it.

Hi @Natalie_Burge - welcome to the forum!

Have you checked if username/password is enabled in your Realm app?

Hi @Andrew_Morgan. thanks for replying! After posting I kept working the problem and realized I’d hadn’t properly enabled the email in the Realm app. That was the problem. I’m now stuck at a new problem! I’m not able to add a task. I’ve combed through the code it looks correct. I’ve spent time in the Realm dashboard checking and rechecking my schemas and database connections. Any ideas? Have you run into something similar?

Hi @Natalie_Burge Are you getting any error messages in the frontend app and/or the Realm logs?

Yes. In the ios emulator. Exception null is not an object ( evaluating ‘projectRealm.write’)
Further under Source it shows code from my TasksProvider.js

const createTask = (newTaskName) => {
const projectRealm = realmRef.current;
projectRealm.write( ( ) => {


The tiny red arrows are pointing to the 3rd line of code: projectRealm.write( ( ) => {
It seems straight forward, but I can’t find any discrepancies between my code and the code example from the tutorial.

The front end terminal is displaying the same error.
ERROR TypeError: null is not an object (evaluating ‘projectRealm.write’)

In the Realm interface I’ve checked and rechecked my schemas. Per the tutorial instructions I used Realm to create my schemas/JSON/BSON objects. But when I try to sync I receive the following error:
Schema Errors/Warnings

Collections with the following schemas will fail to sync.

The following collections have incompatible schemas:

Collection Message
mongodb-atlas.tracker.Task top-level schema for rule “tracker.Task” contains no properties

If you have any ideas, I’d be grateful for the help. I’m new to coding in general and this my first MondoDB project/ first mobile app project.

Are you able to add your version of the app (removing the Realm App Id to a repo (or share a zipped version)?)