Failed to sampleData load for cluster 'myAtlasClusterEDU' - Course [Connecting to MongoDB in Python]

I was attending the first lab for the training Connecting to MongoDB in Python

I got the error below on “Check” button of the lab.
failed to sampleData load for cluster ‘myAtlasClusterEDU’

I terminated the instance in Atlas and recreated and loaded all sample data using the Atlas option to do so.
Still, I am getting the same error.

Please help.


I am in the exact same position as you. Have deleted all other projects. Removed the previous sample data and reloaded and I am still getting same error message :“failed to sampleData load for cluster ‘myAtlasClusterEDU’”

Hey @Alias_Parackal_Kunjicheria/@Octavian_Zagarin1,

Thank you for reaching out to the MongoDB Community forums.

Are you still experiencing the issue? If so, could you please provide a screenshot of the error message you are encountering and the link to the lab?

Look forward to hearing from you.


I have the same issue. I tried deleting all of my collections (sample dataset), it didn’t work, then I deleted entire project, created a new one with the same name and credentials, I imported sample data set, it was imported and then when I try to do check on tutorial, I got the same errror message. Removed everything again and this time I didn’t import dataset, clicked check and still got the same error even though I have enough storage to import it.

The possible issue might be the fact that I created a cluster during first videos, I didn’t wait for the practice video and then I got the issue of needing more storage size to import data, but after deleting everything I’m still getting an error and I don’t get it.

Hey :wave: @Programming_Learning,

Thank you for sharing the screenshot. Could you also provide the link to the lab?


Link to the lab:

The issue is intermittent. Tried exactly the same thing today and it worked. Very annoying and unreliable and it’s very discouraging for new learners.

1 Like

Hi @Octavian_Zagarin1,

Thank you for sharing the link to the lab. I’m glad it worked. However, we will pass on the feedback to the relevant team.

In case of any comments, concerns, or questions, please do not hesitate to reach out.


I’m also having the same issue and I deleted the sample datasets to try to continue with learning but now nothing works in the shell.

If the limit on this test server is 512mb, why does the learning program require us to import a 400+mb data set twice (once through the UI and once through command line). It’s very frustrating! Surely we could learn with just a little sample data set…

The course is pitched at beginners but really assumes a lot of knowledge (that is never specified as a pre requisite) in being comfortable with a terminal command line in Linux.

Please make a truly beginner friendly course or point to resources where I can fill my command line skills gap so that I can do your “beginner” course. Feeling very frustrated and demotivated.

Hi there,

I got the same issue with Lab: Connecting to an Atlas Cluster in PHP Applications from the course Connecting to MongoDB in PHP

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.